spring boot 1+ 禁用 spring security

security.basic.enabled=false

备注:

在某个版本后已经不支持通过该配置禁用了,在 spring-configuration-metadata.json 文件中有明确标识 :

    {
      "name": "security.basic.enabled",
      "type": "java.lang.Boolean",
      "description": "Whether to enable basic authentication.",
      "defaultValue": true,
      "deprecated": true,
      "deprecation": {
        "level": "error",
        "reason": "The security auto-configuration is no longer customizable. Provide your own WebSecurityConfigurer bean instead."
      }
    }

 

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 创作都市 设计师:CSDN官方博客 返回首页